Pling is apparently down

What is happening with the Pling site?
I think that since Friday I can’t access the site, when I try to access it the page tries to load but after a while I get the message that there has been a problem with the connection. And then I tried from several browsers, from the phone, from other computers, from other operating systems and I can not access the site, so I came up with the idea of a million dollars and I connected from a VPN and Bingo! I could finally access, but I can not access from my normal connection, this is a problem with the site, What is happening? because I think I’ve seen something similar before in the forum.

Registered to say that I have the same problem at work.
I noticed it when I tried to get new themes in KDE. I can browse but I get no images. Inspected the pages in firefox and saw that it could not load images from
Tried store.
-kde-org on a computer on the guestnet (another firewall) and worked.

We have a Fortigate, and I’ve managed to trace it to our Application control filter (I’m the admin, made a open rule for my computer and applied layer by layer until I no longer could reach images-pling-com and no images load in store-kde-org)
The only things we have blocked in out Application control policy is “P2P” and “Proxy”.
And I’ve looked into those but can’t find why either would block images-pling-com

I’ve no knowledge about pling, today is the first time I’ve seen the name.
Any ideas as to why pling would trip application control (p2p or proxy) would be nice.
I’m the only affected user at work so this is very low priority, probably spent too much time already, but I got to fiddle around with the firewall and troubleshoot with no pressure which is nice.
Had to put dash in urls cause “new users can only post two links”.

@fkorpsvart If it’s connecting via VPN but not your device it may be a block by your ISP or country. If you send me a message with your IP I can see if it comes up as blocked on our firewall or any connectivity issues to it from our servers.

@hilding There are no p2p services or proxies on our images server. It only has the webserver to provide the images. It’s possible in the past the IP of this server (before we were assigned it) was used for P2P or Proxy services which is why it’s blocked in your Fortigate.

Thanks for your reply @justinz.
And well, it’s not a problem with my ISP or my country, I’ve accessed Gnome Look through the old domain ‘’ and I’ve done it without any problem, except that the loading is a bit slow and some images don’t load, but I can access; I can also access Opendesktop ‘’ without problems, the problem is under the Pling domain, I guess it must be a problem from the servers, evidently it’s not a problem with my ISP or the country.
I hope you can solve the problems soon.

@fkorpsvart Please send me your IP via PM, if it’s only blocked on Pling it may be that your ISP gave you an IP that was previously used for nefarious purposes and was blocked by our server. That’s the only other thing I can think of. That or the DNS server you use hasn’t updated the IP for the Pling website.