Can't load passed Grant Access when attempting to mount NextCloud to KDE Neon

Seriously, the site takes SO long to load as well I can’t seem to do anything, what the heck is going on!?

Clicking on Grant Access when I log into my NextCloud account just gives me a loading indicator and doesn’t go passed that!

I’m using KDE Neon, I’ve tried using both Online Accounts and downloading an appimage from the NextCloud site.

Which site are you having issues loading?

I have just tested and it loads at a reasonable speed for me.

I’ve logged out and seen the same issue as you. I’ve made a configuration change to the Nextcloud server and I am now able to click the Grant Access button and sync my folders.

Can you please try again.

I just tried today and it’s working now, I don’t know what happened but I’ve had the issue for almost 3 days until now…

I made a configuration change. It seems maybe the update to the newest Nextcloud introduced the issue. However it is fixed now, thanks for letting us know.

It seems I have an issue in Fedora 34 now…

I can’t mount NextCloud on GNOME 40 and your documentation isn’t helping :confused:

This is a known issue we are working on. It works in KDE as they have a little more relaxed WebDav requirements.

Okay, When do you think it’ll be fixed?

We do not currently have an ETA for this fix.

Okay, this provider has a LOT of problems… Not I can’t find out how to sync the Nextcloud calendar with an Android app called OneCalendar, it keep saying “Error adding your Nextcloud account: This does not appear to be a valid CalDav server”

The server URL in question auto-fills to this when typing “”:

The Android app in question is this one:

Like I said earlier, we are aware of the issue affecting CalDav connectivity and are working on the issue. Please be patient.

I believe I’ve found and fixed the issue. I’ve tested Nautilus and Evolution and both now work. Can you please test @reallyfesucks.