Can't download anything that 200+ MB bigger

Hello everybody, so today I tried to download custom ROM for my phone (around ~500 megabytes), but when it reaches ~200 megabytes, it gives me an error. What can I do? (I have already tried downloading through different browsers, networks, etc. Here’s the link to the ROM, if its important NusantaraROM - Certus - Android 12L) Hoping for at least little help, thank you in advance and sorry for my bad english, if there’s errors in my words.

Do you have enough space left on your phone?

Yes, of course

I’ve just downloaded one of the ROMs from that product page and it was around 500MB and it downloaded without issue. Can you check from another device or internet connection?

Yes, i tried downloading on different devices, even through free VPNs, but it’s still don’t work😕

This is far from the first time I’ve run into file download issues on this site.

I can’t replicate this issue on any of my devices, does your Internet Service Provider do any throttling? Have you tried on a different internet connection? e.g. some free wifi at a local cafe?

No, anything is alright with my internet provider, I tried downloading on different internet connections.

I suggest you to do a crosscheck like download that file from different device.

Nope, still don’t work :confused: Maybe I’m asking too much, but can somebody upload files to some cloud (for example, upload android 12 and 12L to Google Drive) and give me a link? I no longer want to waste someone else’s time and my own because of problems with downloading files(

@brogo : I have deleted the file from the CDN cache and reconfigured the download settings. Can you please try it again. It would be really interesting to know if it works now.

It’s worked! Thanks so much, I appreciate this help, because this is the only good rom for my device so)

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.