Cannot acces to

Can’t acces to the site since yesterday.

Same here.

Confirm this too.

Me too! :frowning: Any pronouncement from admins yet?

We are aware of the slow performance of the site and are working hard in the background to make it smooth for everyone once more.

I have made a tweak to the configuration to reduce the processing time of queries to our database. It appears far better to me now. Please let me know if the issue is still occurring for you.

It takes a while to switch from page to page.But to some extent it seems to me that it is set.

the website itself works fine now but it seems like all download links are down. Can’t download anything at all

Same thing for me. The website itself is fine but the download links are dead.

It seems upload isn’t working as well

I’ve just tested downloading Mondrian - and had no issues. I also uploaded a Test Product with no issue.

@alexus3570 and @overloadthemethod did you receive any error messages when trying to download or upload. Can you please take screenshots and post them here so I can see them. Thanks.

Hi justinz. At this late hour I tested by downloading some addons and it works now. Let me post the screenshot with the error I got earlier:

Note that I tried installing multiple addons and scripts and got the same error.

This persisted for an hour or so. There’s also a reddit thread on /r/kde with people experiencing the same issues.

It works fine for me now, servers must’ve been down

Thanks. I’ll test with the API as well. We are having some performance issues with the API as well and a new server has been deployed but is still in testing. It will hopefully be deployed in the coming days.

I think it’s fine now