Broken zip archive


Can you upload this or another, similarly big file again on a new product and immediately let us know here, so we can check the md5sum?


Meanwhile, we have uploaded the initial file you posted to the server again, and the md5 stayed the same. That is when we downloaded it from the server, it had the same hash than on the server and now after reuploading the same file to another product, it also has the same hash on the server again:

OP6 - HydrogenOS

So when someone downloads this file, it should also have md5sum of the above.
That means during our cycle with uploading a big file like yours the hash stayed consistent so far here local and on server.

We will keep an eye on the file if anything happens with it, like in case ot would change the md5sum in 1 hour or 24 hours.
If this stays stable, then we assume that the issue lies in uploading the file, since it seems to have ended on the server with a different hashsum than what you have local.

What browser or method do you use to upload the file?


I’m sorry! I was away. I’m uploading files through Brave browser on windows 10.

This md5 is already corrupted. I think new working file should be uploaded. If it is needed i will do it.
Want to remind that first downloads were Ok. I uploaded file for testers and they could flash but day after when i shared with all users problem appeared.

I uploaded new file
OP7Pro -
its md5 545e1dd97cde99697c9556be9d73b684


Hi annalerias,

the hash on the server for your latest file is different again.

Now to find out what is really going on, we want you to download and reupload some file to a test product (please use a new product and label it clearly “Test” or such, so we can compare things), where we know the hash on the server (regardless if its wrong or not):

Please download this ZIP, let us know the hashsum of what you downloaded and Reupload it to a new TEST PRODUCT. Do NOT use your old local file of the same name.
Thank you.


Hello! Ok, will do it right now.


Thanks for helping to find out what might be the cause for the issues on your side.


Product created and file uploaded
OP6 - HydrogenOS


Thanks. What does your local md5sum say for this file?




Great, thanks.
So now the file you downloaded from server had the same hash, which means it got downloaded correctly, then uploaded again correctly to a new file, then confirmed that this file on server also still has the same hash as above.
So the whole chain has worked once, now we will watch if file ever changes over time.

Can you remember if you did anything after uploading your files once, like change version numbers, change text, etc.?


only added name of rom in “version” gap


Hello! Are there any news regarding this problem?


Hi, I am also facing corruption issues. My product is ANXCamera. Recently this file had gone corrupt

Few people were able to download properly yesterday, but today people are reporting corrupt downloads


Hi aeonax,

what is the correct md5sum supposed to be of the original file?


I reuploaded again yesterday

This are the md5 hashes from one of the downloader’s as of yesterday
1cef1ef942b42e508583fa9e0b49e78c <- File I reuploaded

55f1f7069107160dcaeb3c11dd40889f <-File I previously uploaded. Few people were able to successfully download and install this

MD5 hash of the file on my computer:

MD5 hash of J:\ROOT\GitHub\ANXCamera\out\


Thanks aeonax!

We are building a new upload mechanism right now, which will calculate and show the md5sum automatically for each uploaded file, so its easy then to compare if upload went well right away.

We also can then add a button to “recheck” md5sum on the server to make sure it hasnt changed for whatever reason when people experience problems.

Will probably be ready next week.


Any updates? more files have gone corrupt


We have updated our servers, plus added a md5 checksum field in the file upload dialog when adding/editing a product.

We will also add md5sum information for the user on the product page next.


Hi community,

I had difficulties to update my product this morning. Uploading archives in .tar.xz format give me an error when I try to extract it in return. So I re-upload it in .zip format and it worked.

Kind Regards :slight_smile:


Hi bolimage,

did you compare local md5sums before and after download with md5sum on the server?